Schematic Editor menus and toolbar

This section describes schematic editor menus and toolbar

This panel contains the most commonly used commands:

  • Create a new schematic diagram using the New schematic diagram wizard (Figure 1, Figure 2). The wizard allows you to easily create a new schematic diagram with hardware properties that match the HIL device in use. Hardware properties can be set either manually or can be directly obtained from the connected HIL device (by clicking on the Detect hardware settings button, Figure 1).
  • If you click on the Device Table button you can get more detailed information about features available in different firmware configurations.

Figure 1: Schematic diagram settings wizard



Figure 2: Summary



  • Open an existing schematic diagram
  • Save the schematic diagram
  • Save theschematic diagram as …
  • Print a schematic
  • Undo an executed command
  • Redo an executed command
  • Cut the selected item(s)
  • Copy the selected item(s)
  • Paste items
  • Zoom In scene
  • Zoom Out scene
  • Zoom 1:1 (original zoom level)
  • Fit to view
  • Rotate 90’ CW selected component
  • Rotate 90’ CCW selected component
  • Flip the selected component horizontally
  • Flip the selected component vertically
  • Model initialization script, initialize model namespace
  • Compile the schematic diagram
  • Compile and load the model into HIL SCADA
  • Undock/Dock Schematic Editor from Typhoon HIL Control Center

The whole command set can be found in the relevant drop-down menus:

File menu
  • New - Create new model or library file
  • Open - Open schematic or library file
  • Open example model - Open schematic file, folder is going to be set to examples folder
  • Open recent - Open recently used models and libraries
  • Save - Save file
  • Save as - Save file with different name
  • Export library - Export a library as locked library file
  • Close – Close the currently active schematic diagram
  • Import license– import a license file into Typhoon HIL software tool-chain
  • Reload libraries– Refresh library browser, reload all libraries
  • Modify library paths– Edit libraries search paths
  • Import PSIM Schematic Import PSIM Schematic files
  • Export to PDF – Export the schematic diagram as a PDF file
  • Export to image– Export the schematic diagram as an image in various formats
  • Print – Print the schematic diagram
  • Quit - Exit Schematic Editor
Edit menu
  • Select all – Select all items in the scene
  • Delete – Delete the selected item(s)
  • Remove wire/s routing points – Remove all explicitly created wire routing points for all wires in the schematic diagram (keyboard shortcut F4). To remove wire routing points for a single wire, right-click on that wire and then remove wire/s routing points from the context menu.
  • Create subsystem from selection – Create a subsystem from the currently selected schematic elements.
View menu
  • Toggle full screen/normal mode - Toggle between the full screen and the normal view mode, which is available only when Schematic Editor is started as standalone application (keyboard shortcut F11).
  • Show/Hide docks – Enable or disable the selected dock.
Model menu
  • Model initialization – Shows a dialog where model level variables can be defined. These variables are visible throughout the model, so they can be used as values of properties. For example, a Resistor resistance value can be set to R_init (where R_init is defined at the model level using this dialog). In addition to variables, you can also add any valid Python code.
  • Namespace viewer – Displays a dialog which shows the namespace content (variables).
  • Compile schematic – Compile the current schematic model.
  • Compile and open model in HIL SCADA – Compile the current schematic model and load it into HIL SCADA.
  • C code export (beta)- Generate C code from a subset of a model.
  • Visualize execution rates – Activate execution rate visualization and also show execution rate legend dialog.
  • Schematic settings – Shows a dialog for changing schematic settings.
Windows menu
Windows menu – Contains a list of all schematic diagrams.
Help menu
About schematic editor – Shows the About dialog.